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Error code 3012

Failure

The log from the NDD - Supply Watch service recorded error code 3012 (InvalidDriverLanguageException).

Cause

Failure to apply the print saving due to the printer driver not being in the PCL6 language.

The use of a PCL6 driver is a prerequisite for the correct application of print saving via EcoPrint.

Solution

Change the printer driver to the PCL6 language as instructed below:

  1. Download the PCL6 language driver compatible with your printer model from the manufacturer's website

  • If the queue is configured via the NDD Orbix print queues feature:

  1. Access the NDD Orbix portal

  2. Create the driver installed in step 1

  3. Change the print queue driver

  • If the queue is not configured via the NDD Orbix print queues feature:

  1. Go to the Control Panel

  2. Click on Hardware and Sound

  3. Click View printers and devices

  4. Click on Printers and scanners

  5. Locate the desired printer and click on it

  6. Click on Printer properties

  7. In the properties window, click on the Advanced tab

  8. Under Driver, select the driver installed in step 1

  9. Click on the OK button

The steps described were carried out in Windows 11.


If the failure is not resolved using the above solution, we recommend opening a support ticket for assistance in resolving the problem.

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