Error code 3012
Failure
The log from the NDD - Supply Watch service recorded error code 3012 (InvalidDriverLanguageException).
Cause
Failure to apply the print saving due to the printer driver not being in the PCL6 language.
The use of a PCL6 driver is a prerequisite for the correct application of print saving via EcoPrint.
Solution
Change the printer driver to the PCL6 language as instructed below:
Download the PCL6 language driver compatible with your printer model from the manufacturer's website
If the queue is configured via the NDD Orbix print queues feature:
Access the NDD Orbix portal
Create the driver installed in step 1
If the queue is not configured via the NDD Orbix print queues feature:
Go to the Control Panel
Click on Hardware and Sound
Click View printers and devices
Click on Printers and scanners
Locate the desired printer and click on it
Click on Printer properties
In the properties window, click on the Advanced tab
Under Driver, select the driver installed in step 1
Click on the OK button
The steps described were carried out in Windows 11.
If the failure is not resolved using the above solution, we recommend opening a support ticket for assistance in resolving the problem.
{{component-feedback-article}}