Agent does not appear in the portal after installing DCA and Cloud Connector
Failure
After installing DCA and Cloud Connector, the agent does not appear in the NDD Orbix portal.
Cause
In the agent installation folder (C:\NDD TECH\Workfolder\logs), a .txt file was generated with one of the errors. Each error is associated with a specific cause.
Cause 1: failure to insert the client key
[ERR] Agent authentication failed
[{"ErrorCode":null,"ErrorMessage":"{\"ErrorCode\":500,\"ErrorMessage\":
\"Value cannot be null. (Parameter 'request')\"}","PropertyName":null,"$Type":"ApiError"}]
This failure occurs when the customer key was entered incorrectly during agent installation.
Cause 2: invalid class failure
[ERR] Failed to get machine ID Microsoft.Management.Infrastructure.CimException:
Classe inválida at
Microsoft.Management.Infrastructure.Internal.Operations.CimSyncEnumeratorBase`1
.MoveNext() at System.Linq.Enumerable.TryGetFirst[TSource](IEnumerable`1
source, Boolean& found) at
System.Linq.Enumerable.FirstOrDefault[TSource](IEnumerable`1 source) at
NDPAgents.SDK.Common.Helpers.EnviromentSettingsHelper.WindowsEnviromentS
ettingsHelper.GetMachineId() 2025-07-15 17:08:00.375 -03:00 [ERR] Failed to get
machine ID Microsoft.Management.Infrastructure.CimException: Classe inválida
This failure is related to the Windows WMI service, used by DCA and Cloud Connector to collect system and device information.
Cause 3: agent authentication failure
[ERR] Failed to get ram memory from the machine through the
Win32_ComputerSystem class Microsoft.Management.Infrastructure.CimException:
Não encontrado
[ERR] Agent authentication failed
[{"ErrorCode":"NotEmptyValidator","ErrorMessage":"'Machine Id' must not be
empty.","PropertyName":"MachineId","$type":"ApiError"},{"ErrorCode":"NotEmptyVali
dator","ErrorMessage":"'OS' must not be
empty.","PropertyName":"OS","$type":"ApiError"},{"ErrorCode":"LengthValidator","Err
orMessage":"'OS' must be between 1 and 255 characters. You entered 0
characters.","PropertyName":"OS","$type":"ApiError"}
This failure is related to the Windows WMI service, used by DCA and Cloud Connector to collect system and device information.
Solution
Apply the procedure according to the identified cause.
Cause 1 (failure to insert the client key)
Uninstall the DCA and Cloud Connector agent from your computer, as instructed at Remove the agent on Windows
Install the DCA and Cloud Connector agent, ensuring that the customer key is entered correctly, as instructed in Install the agent on Windows
Cause 2 (invalid class failure) or 3 (agent authentication failure)
As a precaution, stop the DCA and Cloud Connector service in Windows:
Open Services Manager as an administrator (Win + R → enter services.msc → OK)
Locate and stop the NDD - DCA and Cloud Connector service
Restore winmgmt:
Open Windows PowerShell as an administrator
Run the command
winmgmt /resetrepository
If no error is returned:
Run the command
(Get-CimInstance -ClassName Win32_ComputerSystemProduct).UUIDIf the GUID is returned, start the DCA and Cloud Connector service in Windows:
Open Services Manager as an administrator (Win + R → enter services.msc → OK)
Locate and start the NDD - DCA and Cloud Connector service
In the NDD Orbix portal, verify that the NDD - DCA and Cloud Connector service is displayed and has a Status of Online, as instructed in View service information
If the message “Unable to execute because there are services or processes running that depend on it” appears:
Run the command
Get-Service -Name winmgmt | Select-Object -ExpandProperty DependentServicesto list the services that are running and depend directly on winmgmt

Example of command return
Stop all services with the status Running:
Run the command
sc.exe stop <serviceName>, replacing<serviceName>with the name of the service
Example
sc.exe stop vmns
After stopping all services, run the command
winmgmt /resetrepositoryStart the DCA and Cloud Connector service in Windows:
Open Services Manager as an administrator (Win + R → enter services.msc → OK)
Locate and start the NDD - DCA and Cloud Connector service
In the NDD Orbix portal, verify that the NDD - DCA and Cloud Connector service is displayed and has a Status of Online, as instructed in View service information
Restart all services that were stopped in step 2:
Run the command
sc.exe start <serviceName>, replacing<serviceName>with the name of the service
Example
sc.exe start vmns