Skip to main content
Skip table of contents

Agent does not appear in the portal after installing DCA and Cloud Connector

Failure

After installing DCA and Cloud Connector, the agent does not appear in the NDD Orbix portal.

Cause

In the agent installation folder (C:\NDD TECH\Workfolder\logs), a .txt file was generated with one of the following errors:

  • Cause 1: invalid class failure:

CODE
[ERR] Failed to get machine ID Microsoft.Management.Infrastructure.CimException: 
Classe inválida at 
Microsoft.Management.Infrastructure.Internal.Operations.CimSyncEnumeratorBase`1
.MoveNext() at System.Linq.Enumerable.TryGetFirst[TSource](IEnumerable`1 
source, Boolean& found) at 
System.Linq.Enumerable.FirstOrDefault[TSource](IEnumerable`1 source) at 
NDPAgents.SDK.Common.Helpers.EnviromentSettingsHelper.WindowsEnviromentS
ettingsHelper.GetMachineId() 2025-07-15 17:08:00.375 -03:00 [ERR] Failed to get 
machine ID Microsoft.Management.Infrastructure.CimException: Classe inválida
  • Cause 2: agent authentication failure:

CODE
[ERR] Failed to get ram memory from the machine through the 
Win32_ComputerSystem class Microsoft.Management.Infrastructure.CimException: 
Não encontrado 

[ERR] Agent authentication failed 
[{"ErrorCode":"NotEmptyValidator","ErrorMessage":"'Machine Id' must not be 
empty.","PropertyName":"MachineId","$type":"ApiError"},{"ErrorCode":"NotEmptyVali
dator","ErrorMessage":"'OS' must not be 
empty.","PropertyName":"OS","$type":"ApiError"},{"ErrorCode":"LengthValidator","Err
orMessage":"'OS' must be between 1 and 255 characters. You entered 0 
characters.","PropertyName":"OS","$type":"ApiError"}

The failures are related to the Windows WMI service, which is used by DCA and Cloud Connector to collect system information and device information.

Solution

  1. As a precaution, stop the DCA and Cloud Connector service in Windows:

    1. Open Services Manager as an administrator (Win + R → enter services.mscOK)

    2. Locate and stop the NDD - DCA and Cloud Connector service

  2. Restore winmgmt:

    1. Open Windows PowerShell as an administrator

    2. Run the command winmgmt /resetrepository

If no error is returned:

  1. Run the command (Get-CimInstance -ClassName Win32_ComputerSystemProduct).UUID

  2. If the GUID is returned, start the DCA and Cloud Connector service in Windows:

    1. Open Services Manager as an administrator (Win + R → enter services.msc OK)

    2. Locate and start the NDD - DCA and Cloud Connector service

  3. In the NDD Orbix portal, verify that the NDD - DCA and Cloud Connector service is displayed and has a Status of Online, as instructed in View service information

If the message “Unable to execute because there are services or processes running that depend on it appears:

  1. Run the command Get-Service -Name winmgmt | Select-Object -ExpandProperty DependentServices to list the services that are running and depend directly on winmgmt

image-20251003-182526.png

Example of command return

  1. Stop all services with the status Running:

    1. Run the command sc.exe stop <serviceName>, replacing <serviceName> with the name of the service

Example

sc.exe stop vmns

  1. After stopping all services, run the command winmgmt /resetrepository

  2. Start the DCA and Cloud Connector service in Windows:

    1. Open Services Manager as an administrator (Win + R → enter services.msc OK)

    2. Locate and start the NDD - DCA and Cloud Connector service

  3. In the NDD Orbix portal, verify that the NDD - DCA and Cloud Connector service is displayed and has a Status of Online, as instructed in View service information

  4. Restart all services that were stopped in step 2:

    1. Run the command sc.exe start <serviceName>, replacing <serviceName> with the name of the service

Example

sc.exe start vmns

JavaScript errors detected

Please note, these errors can depend on your browser setup.

If this problem persists, please contact our support.