Agente não é exibido no portal após instalação do DCA and Cloud Connector
Falha
Após instalar o DCA and Cloud Connector, o agente não é exibido no portal NDD Orbix.
Causa
Na pasta de instalação do agente (C:\NDD TECH\Workfolder\logs), um arquivo .txt foi gerado com um dos erros. Cada erro está associado a uma causa específica.
Causa 1: falha na inserção da chave do cliente
[ERR] Agent authentication failed
[{"ErrorCode":null,"ErrorMessage":"{\"ErrorCode\":500,\"ErrorMessage\":
\"Value cannot be null. (Parameter 'request')\"}","PropertyName":null,"$Type":"ApiError"}]
Essa falha ocorre quando a chave do cliente foi inserida incorretamente durante a instalação do agente.
Causa 2: falha de classe inválida
[ERR] Failed to get machine ID Microsoft.Management.Infrastructure.CimException:
Classe inválida at
Microsoft.Management.Infrastructure.Internal.Operations.CimSyncEnumeratorBase`1
.MoveNext() at System.Linq.Enumerable.TryGetFirst[TSource](IEnumerable`1
source, Boolean& found) at
System.Linq.Enumerable.FirstOrDefault[TSource](IEnumerable`1 source) at
NDPAgents.SDK.Common.Helpers.EnviromentSettingsHelper.WindowsEnviromentS
ettingsHelper.GetMachineId() 2025-07-15 17:08:00.375 -03:00 [ERR] Failed to get
machine ID Microsoft.Management.Infrastructure.CimException: Classe inválida
Essa falha está relacionada ao serviço WMI do Windows, utilizado pelo DCA and Cloud Connector para coletar informações do sistema e dos dispositivos.
Causa 3: falha de autenticação do agente
[ERR] Failed to get ram memory from the machine through the
Win32_ComputerSystem class Microsoft.Management.Infrastructure.CimException:
Não encontrado
[ERR] Agent authentication failed
[{"ErrorCode":"NotEmptyValidator","ErrorMessage":"'Machine Id' must not be
empty.","PropertyName":"MachineId","$type":"ApiError"},{"ErrorCode":"NotEmptyVali
dator","ErrorMessage":"'OS' must not be
empty.","PropertyName":"OS","$type":"ApiError"},{"ErrorCode":"LengthValidator","Err
orMessage":"'OS' must be between 1 and 255 characters. You entered 0
characters.","PropertyName":"OS","$type":"ApiError"}
Essa falha está relacionada ao serviço WMI do Windows, utilizado pelo DCA and Cloud Connector para coletar informações do sistema e dos dispositivos.
Solução
Aplique o procedimento conforme a causa identificada.
Causa 1 (falha na inserção da chave do cliente)
Desinstale o agente DCA and Cloud Connector do computador, conforme instruído em Remover o agente no Windows
Instale o agente DCA and Cloud Connector novamente, garantindo que a chave do cliente seja inserida de forma correta, conforme instruído em Instalar o agente no Windows
Causa 2 (falha de classe inválida) ou 3 (falha de autenticação do agente)
Por precaução, pare o serviço DCA and Cloud Connector no Windows:
Abra o Gerenciador de Serviços como administrador (Win + R → digite services.msc → OK)
Localize e pare o serviço NDD - DCA and Cloud Connector
Restaure o winmgmt:
Abra o Windows PowerShell como administrador
Execute o comando
winmgmt /resetrepository
Se não retornar erro:
Execute o comando
(Get-CimInstance -ClassName Win32_ComputerSystemProduct).UUIDCaso o GUID seja retornado, inicie o serviço DCA and Cloud Connector no Windows:
Abra o Gerenciador de Serviços como administrador (Win + R → digite services.msc → OK)
Localize e inicie o serviço NDD - DCA and Cloud Connector
No portal NDD Orbix, verifique se o serviço NDD - DCA and Cloud Connector é exibido e está com o Status como Online, conforme instruído em Visualizar informações dos serviços
Se retornar a mensagem “Impossível executar, pois há serviços ou processos rodando que dependem dele”:
Execute o comando
Get-Service -Name winmgmt | Select-Object -ExpandProperty DependentServicespara listar os serviços que estão rodando e dependem diretamente do winmgmt

Exemplo de retorno do comando
Pare todos os serviços com o status Running:
Execute o comando
sc.exe stop <serviceName>, substituindo<serviceName>pelo nome do serviço
Exemplo
sc.exe stop vmns
Após parar todos os serviços, execute o comando
winmgmt /resetrepositoryInicie o serviço DCA and Cloud Connector no Windows:
Abra o Gerenciador de Serviços como administrador (Win + R → digite services.msc → OK)
Localize e inicie o serviço NDD - DCA and Cloud Connector
No portal NDD Orbix, verifique se o serviço NDD - DCA and Cloud Connector é exibido e está com o Status como Online, conforme instruído em Visualizar informações dos serviços
Reinicie todos os serviços que foram parados no passo 2:
Execute o comando
sc.exe start <serviceName>, substituindo<serviceName>pelo nome do serviço
Exemplo
sc.exe start vmns