Skip to main content
Skip table of contents

Agente no aparece en el portal tras instalar DCA and Cloud Connector

Falla

Tras instalar DCA and Cloud Connector, el agente no aparece en el portal NDD Orbix.

Causa

En la carpeta de instalación del agente (C:\NDD TECH\Workfolder\logs), se ha generado un archivo .txt con uno de los siguientes errores:

  • Causa 1: falla de clase no válida:

CODE
[ERR] Failed to get machine ID Microsoft.Management.Infrastructure.CimException: 
Classe inválida at 
Microsoft.Management.Infrastructure.Internal.Operations.CimSyncEnumeratorBase`1
.MoveNext() at System.Linq.Enumerable.TryGetFirst[TSource](IEnumerable`1 
source, Boolean& found) at 
System.Linq.Enumerable.FirstOrDefault[TSource](IEnumerable`1 source) at 
NDPAgents.SDK.Common.Helpers.EnviromentSettingsHelper.WindowsEnviromentS
ettingsHelper.GetMachineId() 2025-07-15 17:08:00.375 -03:00 [ERR] Failed to get 
machine ID Microsoft.Management.Infrastructure.CimException: Classe inválida
  • Causa 2: falla de autenticación del agente:

CODE
[ERR] Failed to get ram memory from the machine through the 
Win32_ComputerSystem class Microsoft.Management.Infrastructure.CimException: 
Não encontrado 

[ERR] Agent authentication failed 
[{"ErrorCode":"NotEmptyValidator","ErrorMessage":"'Machine Id' must not be 
empty.","PropertyName":"MachineId","$type":"ApiError"},{"ErrorCode":"NotEmptyVali
dator","ErrorMessage":"'OS' must not be 
empty.","PropertyName":"OS","$type":"ApiError"},{"ErrorCode":"LengthValidator","Err
orMessage":"'OS' must be between 1 and 255 characters. You entered 0 
characters.","PropertyName":"OS","$type":"ApiError"}

Las fallas están relacionadas con el servicio WMI de Windows, utilizado por DCA and Cloud Connector para recopilar información del sistema y de los dispositivos.

Solución

  1. Por precaución, detenga el servicio DCA and Cloud Connector en Windows:

    1. Abra el Administrador de servicios como administrador (Win + R → introduzca services.msc OK)

    2. Busque y detenga el servicio NDD - DCA and Cloud Connector

  2. Restaure winmgmt:

    1. Abra Windows PowerShell como administrador

    2. Ejecute el comando winmgmt /resetrepository

Si no devuelve ningún error:

  1. Ejecute el comando (Get-CimInstance -ClassName Win32_ComputerSystemProduct).UUID

  2. Si se devuelve el GUID, inicie el servicio DCA and Cloud Connector en Windows:

    1. Abra el Administrador de servicios como administrador (Win + R → introduzca services.msc OK)

    2. Busque y arranque el servicio NDD - DCA and Cloud Connector

  3. En el portal NDD Orbix, compruebe que el servicio NDD - DCA and Cloud Connector aparece y tiene el Estado Online, tal y como se indica en Ver informaciones de los servicios

Si aparece el mensaje “Imposible ejecutar, ya que hay servicios o procesos en ejecución que dependen de él:

  1. Ejecute el comando Get-Service -Name winmgmt | Select-Object -ExpandProperty DependentServices para enumerar los servicios que se están ejecutando y que dependen directamente de winmgmt

image-20251003-182526.png

Ejemplo de retorno del comando

  1. Detenga todos los servicios con el estado Running:

    1. Ejecute el comando sc.exe stop <serviceName>, sustituyendo <serviceName> por el nombre del servicio

Ejemplo

sc.exe stop vmns

  1. Después de detener todos los servicios, ejecute el comando winmgmt /resetrepository

  2. Inicie el servicio DCA and Cloud Connector en Windows:

    1. Abra el Administrador de servicios como administrador (Win + R → introduzca services.msc OK)

    2. Busque y arranque el servicio NDD - DCA and Cloud Connector

  3. En el portal NDD Orbix, compruebe que el servicio NDD - DCA and Cloud Connector aparece y tiene el Estado Online, tal y como se indica en Ver informaciones de los servicios

  4. Reinicie todos los servicios que se detuvieron en el paso 2:

    1. Ejecute el comando sc.exe start <serviceName>, sustituyendo <serviceName> por el nombre del servicio

Ejemplo

sc.exe start vmns

JavaScript errors detected

Please note, these errors can depend on your browser setup.

If this problem persists, please contact our support.