Error code 8007
Failure
The log from the NDD - Printer Monitor service recorded error code 8007 (PrinterKeyIsNullException).
Cause
The service was unable to locate the printer's serial number (serialNumber) or MAC address (MACAddress) in the information saved in the database, or the read information was empty.
Solution
Verify that the database is in the default directory.
If the database is present in the correct location, verify that the service has the appropriate permissions to access this directory.
If the failure is not resolved using the solutions above, we recommend opening a support ticket for assistance in resolving the problem.
{{component-feedback-article}}