Skip to main content
Skip table of contents

PCL6 driver language error on Epson or Canon printers, even with the correct driver installed

Failure

Even with the PCL6 driver installed, the error log indicates that the language used is not PCL6.

imagem (4)-20250804-181826.png

Driver language error log

Cause

Some drivers, especially for Epson and Canon printers, require additional settings in the driver properties to ensure that jobs are processed correctly in PCL6 language.

Solution

For Epson printers, follow the steps below:

  1. Access the Printers and scanners menu in Windows

  2. Click on the printer

  3. Click on Printing preferences

  4. Click on the Maintenance tab

  5. Click on Advanced settings

  6. In the Printer control language field, select PCL6

  7. Click on OK to save the changes

Image (3)-20250804-182207.jpg

Advanced settings in printing preferences

For Canon printers, follow the steps below:

  1. Access the Printers and scanners menu in Windows

  2. Click on the printer

  3. Click on Printer Properties

  4. Click on the Device Settings tab

  5. In the Config. Profile field, click on Change

  6. Select the Basic Configuration (Compatible) option

  7. Click on OK to save the changes

imagem (5)-20250804-182618.png

Device settings in printer properties

After making these adjustments, print jobs should be sent correctly using PCL6 language.

JavaScript errors detected

Please note, these errors can depend on your browser setup.

If this problem persists, please contact our support.